BETA

31st March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [31/03/19 08:55 PM] with 'Partial Outage'

Issue has been resolved at [31/03/19 08:57 PM]