BETA

31st March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [31/03/19 04:40 PM] with 'Partial Outage'

Issue has been resolved at [31/03/19 04:43 PM]