BETA

31st March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [31/03/19 04:11 PM] with 'Partial Outage'

Issue has been resolved at [31/03/19 04:15 PM]