BETA

31st March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [31/03/19 02:47 PM] with 'Partial Outage'

Issue has been resolved at [31/03/19 02:48 PM]