BETA

8th November 2016

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [08/11/16 11:00 AM] with 'Partial Outage'

Issue has been resolved at [08/11/16 11:01 AM]