BETA

30th March 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [30/03/19 01:09 PM] with 'Major Outage'

Issue has been resolved at [30/03/19 01:10 PM]