BETA

29th March 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [29/03/19 06:21 PM] with 'Partial Outage'

Issue has been resolved at [29/03/19 06:23 PM]