BETA

29th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [29/03/19 05:23 PM] with 'Partial Outage'

Issue has been resolved at [29/03/19 05:24 PM]