BETA

29th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [29/03/19 04:33 PM] with 'Partial Outage'

Issue has been resolved at [29/03/19 04:35 PM]