BETA

28th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [28/03/19 08:47 PM] with 'Partial Outage'

Issue has been resolved at [28/03/19 08:48 PM]