BETA

28th March 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [28/03/19 01:23 PM] with 'Major Outage'

Issue has been resolved at [28/03/19 01:30 PM]