BETA

28th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [28/03/19 10:10 AM] with 'Major Outage'

Issue has been resolved at [28/03/19 10:11 AM]