BETA

3rd November 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/11/16 04:23 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/11/16 04:35 PM]