BETA

1st November 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [01/11/16 12:11 AM] with 'Major Outage'

Issue has been resolved at [01/11/16 12:19 AM]