BETA

28th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [28/03/19 07:59 AM] with 'Major Outage'

Issue has been resolved at [28/03/19 08:03 AM]