BETA

1st November 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/11/16 12:11 AM] with 'Partial Outage'

Issue has been resolved at [01/11/16 12:19 AM]