BETA

28th October 2016

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [28/10/16 03:51 PM] with 'Partial Outage'

Issue has been resolved at [28/10/16 04:11 PM]