BETA

26th October 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/10/16 08:58 PM] with 'Major Outage'

Issue has been resolved at [26/10/16 09:04 PM]