BETA

21st October 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/10/16 04:38 PM] with 'Major Outage'

Issue has been resolved at [21/10/16 04:46 PM]