BETA

28th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/03/19 05:11 AM] with 'Partial Outage'

Issue has been resolved at [28/03/19 05:12 AM]