BETA

28th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [28/03/19 05:09 AM] with 'Major Outage'

Issue has been resolved at [28/03/19 05:10 AM]