BETA

28th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [28/03/19 05:07 AM] with 'Partial Outage'

Issue has been resolved at [28/03/19 05:09 AM]