BETA

10th October 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [10/10/16 12:08 PM] with 'Partial Outage'

Issue has been resolved at [10/10/16 12:09 PM]