BETA

28th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [28/03/19 04:29 AM] with 'Partial Outage'

Issue has been resolved at [28/03/19 04:35 AM]