BETA

28th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [28/03/19 04:21 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/19 04:37 AM]