BETA

28th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [28/03/19 03:59 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/19 04:06 AM]