BETA

10th October 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/10/16 12:07 AM] with 'Partial Outage'

Issue has been resolved at [10/10/16 12:15 AM]