BETA

11th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [11/12/17 12:27 PM] with 'Major Outage'

Issue has been resolved at [11/12/17 12:28 PM]