BETA

10th October 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/10/16 12:06 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [10/10/16 12:14 AM]