BETA

28th March 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [28/03/19 03:03 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/19 03:19 AM]