BETA

11th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/12/17 11:15 AM] with 'Major Outage'

Issue has been resolved at [11/12/17 11:16 AM]