BETA

9th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [09/12/17 04:32 PM] with 'Partial Outage'

Issue has been resolved at [09/12/17 04:33 PM]