BETA

9th October 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/10/16 12:10 AM] with 'Partial Outage'

Issue has been resolved at [09/10/16 12:14 AM]