BETA

8th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [08/12/17 07:22 PM] with 'Major Outage'

Issue has been resolved at [08/12/17 07:26 PM]