BETA

28th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/03/19 02:00 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/19 02:15 AM]