BETA

8th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [08/12/17 02:52 PM] with 'Major Outage'

Issue has been resolved at [08/12/17 02:53 PM]