BETA

8th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/12/17 02:29 PM] with 'Major Outage'

Issue has been resolved at [08/12/17 02:30 PM]