BETA

28th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [28/03/19 12:45 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/19 01:03 AM]