BETA

8th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [08/12/17 12:51 PM] with 'Partial Outage'

Issue has been resolved at [08/12/17 12:52 PM]