BETA

8th December 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [08/12/17 12:36 PM] with 'Major Outage'

Issue has been resolved at [08/12/17 12:37 PM]