BETA

8th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [08/12/17 12:36 PM] with 'Major Outage'

Issue has been resolved at [08/12/17 12:38 PM]