BETA

27th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/03/19 11:25 PM] with 'Major Outage'

Issue has been resolved at [27/03/19 11:29 PM]