BETA

8th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [08/12/17 12:08 PM] with 'Partial Outage'

Issue has been resolved at [08/12/17 12:09 PM]