BETA

27th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/03/19 10:00 PM] with 'Partial Outage'

Issue has been resolved at [27/03/19 10:01 PM]