BETA

27th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [27/03/19 09:55 PM] with 'Major Outage'

Issue has been resolved at [27/03/19 10:01 PM]