BETA

8th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [08/12/17 10:41 AM] with 'Major Outage'

Issue has been resolved at [08/12/17 10:42 AM]