BETA

27th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/03/19 09:45 PM] with 'Partial Outage'

Issue has been resolved at [27/03/19 09:47 PM]