BETA

1st October 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [01/10/16 08:22 AM] with 'Major Outage'

Issue has been resolved at [01/10/16 08:34 AM]