BETA

27th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/03/19 08:15 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/03/19 08:37 PM]