BETA

27th March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [27/03/19 08:13 PM] with 'Partial Outage'

Issue has been resolved at [27/03/19 08:24 PM]